Cyber Guru Platform - Self-service password recovery temporarily disabled

Incident Report for LibraCyber

Update

The permanent fix for this issue has been fully validated and is scheduled for deployment during a maintenance window on Friday, August 28, 18:00–24:00 CEST.
Following the upgrade, self-service password recovery ("Forgot password") will be progressively re-enabled across all customers, and we expect the feature to be fully restored shortly after the maintenance window.
In the meantime, password resets performed by your platform administrators continue to work normally.
Posted Aug 26, 2026 - 17:10 CEST

Identified

As a precautionary security measure, the "Forgot password" self-service function on the platform login page has been temporarily disabled.
Impact: users who do not remember their password cannot reset it autonomously. Login with existing credentials and all other platform features are working normally.
Workaround: company administrators can reset user passwords directly from the administration panel. Alternatively, please contact our support team: https://support.libracyber.com/hc/en-us/requests/new
We are working to safely restore the functionality and will post updates here.
Posted Aug 25, 2026 - 18:28 CEST
This incident affects: Services (Cyber Guru App).